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CHECK ACCESSIBILITY OF PDFS 
A good way to check the accessibility of a document is to use tools that your readers will use. Even if you do 

not have access to those tools, Adobe Acrobat provides an automated way to check the accessibility of a PDF 

file. You will need to have access to Adobe Acrobat Pro.  

 

FULL CHECK/ACCESSIBILITY CHECK  

The Full Check/Accessibility Check feature in Acrobat checks a PDF for many of the characteristics of 
accessible PDFs. You can choose which accessibility problems to look for and how you want the results 
reported. 
 
Follow these steps to run the Full Check/Accessibility Check:  

1. Choose Tools then Accessibility. The Accessibility toolset is displayed in the secondary toolbar.  
2. In the secondary toolbar, click Full Check/Accessibility Check. The Accessibility Checker Options dialog 

box is displayed. 

 
3. In the Report Options section, select options for how you want to view the results. You can save the 

results as an HTML file on your system or attach the results file to the document itself. 
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4. Select a page range if you prefer to check individual pages of a document. 
Note: When you have a large document, running a full check/accessibility check one page at a time can be 
more efficient.  

 
5. Select one, more or all of the Checking Options. 
6. Click Start Checking. The results are displayed in the Accessibility Checker panel on the left, which also 

has helpful links and hints for repairing issues. If you created a report in step 2, the results are available 
in the selected folder. 

 
 

THE REPORT  

Because the Full Check/Accessibility Check feature cannot distinguish between essential and nonessential 
content types, some issues it reports don’t affect readability. It’s a good idea to review all issues to determine 
which ones require correction. 
 
The report displays one of the following statuses for each rule check: 

• Passed: The item is accessible. 

• Skipped By User: Rule was not checked because it wasn't selected in the Accessibility Checker 

Options dialog box. 
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• Needs Manual Check: The Full Check/Accessibility Check feature couldn't check the item 

automatically. Verify the item manually. 

• Failed: The item didn't pass the accessibility check. 

 
 

NOTE:  

In addition to Full Check/Accessibility Check, Acrobat provides other methods to check PDF accessibility: 
• Use Reflow view to quickly check the reading order. 
• Use Read Out Loud to experience the document as readers who use the text-to-speech conversion tool 

experience it. 
• Save the document as accessible text and then read the saved text file in a word-processing 

application. This exercise enables you to emulate the end-user experience of readers who use a braille 
printer to read the document. 

• Use the Reading Order tool, Order, Tags, and Content panels to examine the structure, reading order, 
and contents of a PDF. 

 

FIX ACCESSIBILITY ISSUES (ACROBAT PRO) 

To fix a failed check after running Full Check/Accessibility Check, right-click (Windows) or Ctrl-click (Mac OS) 
the item in the Accessibility Checker panel. Choose one of the following options from the context menu: 

• Fix: Acrobat either fixes the item automatically or displays a dialog box prompting you to fix the item 
manually. 

• Skip Rule: Deselects this option in the Accessibility Checker Options dialog box for future checks of this 
document and changes the item status to Skipped. 

• Explain: Opens the online Help  where you can get more details about the accessibility issue. 
• Check Again: Runs the checker again on all items. Choose this option after modifying one or more 

items. 
• Show Report: Displays a report with links to tips on how to repair failed checks. 

https://helpx.adobe.com/acrobat/using/reading-pdfs-reflow-accessibility-features.html#reflow_a_pdf
https://helpx.adobe.com/acrobat/using/reading-pdfs-reflow-accessibility-features.html#read_a_pdf_with_read_out_loud
https://helpx.adobe.com/acrobat/using/touch-reading-order-tool-pdfs.html
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• Options: Opens the Accessibility Checker Options dialog box, so you can select which checks are 
performed. 

 

ACCESSIBILITY ISSUES IN DOCUMENTS 

PREVENT SECURITY SETTINGS FROM INTERFERING WITH SCREEN READERS  

A document author can specify that no part of an accessible PDF is to be copied, printed, extracted, 
commented on, or edited. This setting could interfere with a screen reader's ability to read the document, 
because screen readers must be able to copy or extract the document's text to convert it to speech. This flag 
reports whether it's necessary to turn on the security settings that allow accessibility. 
 
To fix the rule automatically, select Accessibility Permission Flag on the Accessibility Checker panel. Then, 

choose Fix from the Options  menu.  
Or fix accessibility permissions manually: 

1. Choose File > Properties > Security. 
2. Choose No Security from the Security Method drop-down list. 
3. Click OK and close the Document Properties dialog box. 
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If your assistive technology product is registered with Adobe as a Trusted Agent, you can read PDFs that might 
be inaccessible to another assistive technology product. Acrobat recognizes when a screen reader or other 
product is a Trusted Agent and overrides security settings that would typically limit access to the content for 
accessibility purposes. However, the security settings remain in effect for all other purposes, such as to 
prevent printing, copying, extracting, commenting, or editing text. 
 

IMAGE-ONLY PDF 

Reports whether the document contains non-text content that is not accessible. If the document appears to 
contain text, but doesn't contain fonts, it could be an image-only PDF file. 
To fix this rule check automatically, select Image-only PDF on the Accessibility Checker panel, and choose Fix 

from the Options  menu.  
 
Or, to fix this rule check manually, use OCR to recognize text in scanned images: 

1. Choose Tools > Scan & OCR. The Scan toolset is displayed in the secondary toolbar. 
2. In the secondary toolbar, choose Recognize Text > In This File. 
3. Select the pages you want to process, the document language, and then click Recognize Text. 
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TAGGED PDF 

If this rule check fails, the document isn't tagged to specify the correct reading order. 
To fix this item automatically, select Tagged PDF on the Accessibility Checker panel, and then choose Fix from 

the Options  menu. Acrobat automatically adds tags to the PDF.  
 
To specify tags manually, do one of the following: 

• Enable tagging in the application in which the PDF was authored and re-create the PDF. 
• Choose Tools > Accessibility > Auto tag Document in Acrobat. The Add Tags Report appears in the 

navigation pane if there are any issues. The report lists potential problems by page, provides a 
navigational link to each problem, and provides suggestions for fixing them. 

 
 
• Choose Tools > Accessibility > Reading Order in Acrobat and create the tags tree. For more 

information, see Reading Order tool overview. 

 

https://helpx.adobe.com/acrobat/using/touch-reading-order-tool-pdfs.html
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• Open the Tags  panel and create the tags tree manually. To display the Tags panel, choose View > 
Show/Hide > Navigation Panes > Tags. For more information, see Edit document structure with the 
Content and Tags panel. 

 
 

LOGICAL READING ORDER 

Verify this rule check manually. Make sure that the reading order displayed in the Tags panel coincides with 
the logical reading order of the document. 
(Screen shot coming soon) 
 

DOCUMENT LANGUAGE 

Setting the document language in a PDF enables some screen readers to switch to the appropriate language. 
This check determines whether the primary text language for the PDF is specified. If the check fails, set the 
language. 
To set the language automatically, select Primary Language in the Accessibility Checker tab, and then choose 

Fix from the Options  menu. Choose a language in the Set Reading Language dialog box, and then click OK. 
 
To set the language manually, do one of the following: 

• Choose File > Properties > Advanced and then select a language from the drop-down list in the 
Reading Options section. (If the language doesn't appear in the drop-down list, you can enter the ISO 
639 code for the language in the Language field.) This setting applies the primary language for the 
entire PDF. 

 

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html


FLORIDA ATLANTIC UNIVERSITY 

STUDENT  ACCESSIBILITY SERVICES &  INSTRUCTIONAL TECHNOLOGIES 

 
Ally Resource Library 

CHECK ACCESSIBILITY OF PDFS| Updated 3/25/2022 

8 | P a g e  

• Set the language for all text in a subtree of the tags tree. Open the Tags  panel. Expand the Tags 

root and select an element. Then choose Properties from the Options  menu. Choose a language 
from the Language drop-down list. (To display the Tags panel, choose View > Show/Hide > Navigation 
Panes > Tags.) 

• Set the language for a block of text by selecting the text element or container element in the Content 

 panel. Then, right-click (Windows) or Ctrl-click (Mac OS) the text and choose Properties from the 
context menu and choose a language from the Language drop-down list. (To display the Content panel, 
choose View > Show/Hide > Navigation Panes > Content.) 

(Screen shot coming soon) 
 

TITLE 

Reports whether there is a title in the Acrobat application title bar. 

To fix the title automatically, select Title in the Accessibility Checker tab, and choose Fix from the Options  
menu. Enter the document title in the Description dialog box (deselect Leave as Is, if necessary).  
 
Or fix the title manually: 

1. Choose File > Properties > Description. 
2. Enter a title in the Title text box. 
3. Click Initial View, and then choose Document Title from the Show drop-down list.  
4. Click OK to close the Description dialog box. 

 
 

BOOKMARKS 

This check fails when the document has 21 or more pages but doesn't have bookmarks that parallel the 
document structure. 
 
To add bookmarks to the document, select Bookmarks on the Accessibility Checker panel, and choose Fix 

from the Options  menu. In the Structure Elements dialog box, select the elements that you want to use as 
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bookmarks, and click OK. (You can also access the Structure Elements dialog box by clicking the Options menu 
on the Bookmark tab and selecting the New Bookmarks from Structure command.) 
(Screen shot coming soon) 
 

COLOR CONTRAST 

When this check fails, it's possible that the document contains content that isn't accessible to people who are 
color-blind. 
To fix this issue, make sure that the document's content adheres to the guidelines outlined in WCAG section 
1.4.3.  
Or include a recommendation that the PDF viewer use high-contrast colors: 

1. Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS). 
2. Click Accessibility. 
3. Select Replace Document Colors, and then select Use High-Contrast Colors. Choose the color 

combination that you want from the drop-down list, and then click OK. 

 
 

ACCESSIBILITY ISSUES IN PAGE CONTENT 

TAGGED CONTENT 

This check reports whether all content in the document is tagged. Make sure that all content in the document 
is either included in the Tags tree or marked as an artifact.  
Do one of the following to fix this rule check: 

• Open the Content  panel and right-click (Windows) or Ctrl-click (Mac OS) the content that you want 
to mark as an artifact. Then, select Create Artifact from the context menu. (To display the Content tab, 
choose View > Show/Hide > Navigation Panes > Content.) 

• Tag the content by choosing Tools > Accessibility > Reading Order. Select the content, and then apply 
tags as necessary. 

• Assign tags using the Tags  panel. Right-click (Windows) or Ctrl-click (Mac OS) the element in the 
Tags tree and choose Create Tag from Selection. Items such as comments, links, and annotations don't 
always appear in the Tags tree. To find these items, choose Find from the Options menu. (To display 
the Tags panel, choose View > Show/Hide > Navigation Panes > Tags.) 

(Screen shot coming soon) 
 
 

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html#main-pars_table_0
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TAGGED ANNOTATIONS 

This rule checks whether all annotations are tagged. Make sure that annotations such as comments and 
editorial marks (such as insert and highlight) are either included in the Tags tree or marked as artifacts. 

• Open the Content  panel, and right-click (Windows) or Ctrl-click (Mac OS) the content that you want 
to mark as an artifact. Then, select Create Artifact from the context menu. (To display the Content 
panel, choose View > Show/Hide > Navigation Panes > Content.) 

• Tag the content by choosing Tools > Accessibility > Reading Order. Select the content, and then apply 
tags as necessary. 

• Assign tags using the Tags  panel. (To display the Tags panel, choose View > Show/Hide > 
Navigation Panes > Tags.) 

 
To have Acrobat assign tags automatically to annotations as they're created, choose Tag Annotations from the 
Options menu on the Tags panel. 
(Screen shot coming soon) 
 

TAB ORDER 

Because tabs are often used to navigate a PDF, it's necessary that the tab order parallels the document 
structure. 
To fix the tab order automatically, select Tab Order on the Accessibility Checker panel, and choose Fix from 

the Options  menu.  
To manually fix the tab order for links, form fields, comments, and other annotations: 

1. Click the Page Thumbnails panel on the navigation pane. 

2. Click a page thumbnail, and then choose Page Properties from the Options  menu. 
3. In the Page Properties dialog box, choose Tab Order. Then, select Use Document Structure, and click 

OK. 
4. Repeat these steps for all thumbnails in the document. 
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CHARACTER ENCODING 

Specifying the encoding helps PDF viewers' present users with readable text. However, some character-
encoding issues aren't repairable within Acrobat.  
 
To ensure proper encoding, do the following: 

• Verify that the necessary fonts are installed on your system. 
• Use a different font (preferably OpenType) in the original document, and then re-create the PDF. 
• Re-create the PDF file with a newer version of Acrobat Distiller. 
• Use the latest Adobe Postscript driver to create the PostScript file, and then re-create the PDF. 

 

TAGGED MULTIMEDIA 

This rule checks whether all multimedia objects are tagged. Make sure that content is either included in the 
Tags tree or marked as an artifact. 

Open the Content  panel and right-click (Windows) or Ctrl-click (Mac OS) the content that you want to 
mark as an artifact. Then, select Create Artifact from the context menu. (To display the Content panel, choose 
View > Show/Hide > Navigation Panes > Content.) 
Tag the content by choosing Tools > Accessibility > Reading Order. Select the content, and then apply tags as 
necessary. 

Assign tags using the Tags  panel. Right-click (Windows) or Ctrl-click (Mac OS) the element in the Tags tree 
and choose Create Tag from Selection. (To display the Tags panel, choose View > Show/Hide > Navigation 
Panes > Tags.) 
(Screen shot coming soon) 
 

SCREEN FLICKER 

Elements that make the screen flicker, such as animations and scripts, can cause seizures in individuals who 
have photosensitive epilepsy. These elements can also be difficult to see when the screen is magnified. 
If the Screen Flicker rule fails, manually remove, or modify the script or content that causes screen flicker. 
 

SCRIPTS 

Content cannot be script-dependent unless both content and functionality are accessible to assistive 
technologies. Make sure that scripting doesn't interfere with keyboard navigation or prevent the use of any 
input device. 
Check the scripts manually. Remove or modify any script or content that compromises accessibility. 
 

TIMED RESPONSES 

This rule check applies to documents that contain forms with JavaScript. If the rule check fails, make sure that 
the page does not require timed responses. Edit or remove scripts that impose timely user response so that 
users have enough time to read and use the content. 
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ACCESSIBLE LINKS 

For URLs to be accessible to screen readers, they must be active links that are correctly tagged in the PDF. The 
best way to create accessible links is with the Create Link command, which adds all three links that screen 
readers require to recognize a link. Make sure that navigation links are not repetitive and that there is a way 
for users to skip over repetitive links. 
If this rule check fails, check navigation links manually and verify that the content does not have too many 
identical links. Also, provide a way for users to skip over items that appear multiple times. For example, if the 
same links appear on each page of the document, also include a "Skip navigation" link. 
 

ACCESSIBILITY ISSUES IN FORMS 

TAGGED FORM FIELDS 

In an accessible PDF, all form fields are tagged and are a part of the document structure. In addition, you can 
use the tool tip form filed property to provide the user with information or to provide instructions. 
To tag form fields, choose Tools > Accessibility > Auto tag Form Fields. 
 

FIELD DESCRIPTIONS 

For accessibility, all form fields need a text description (tool tip).  
To add a text description to a form field: 

1. Select one of the Form tools, and then right-click (Windows) or Ctrl-click (Mac OS) the form field. 
2. Choose Properties from the context menu. 
3. Click the General properties tab. 
4. Enter a description of the form field in the Tooltip field. 

(Screen shot coming soon) 
 

ACCESSIBILITY ISSUES IN ALTERNATE TEXT 

FIGURES ALTERNATE TEXT 

Make sure that images in the document either have alternate text or are marked as artifacts.  
If this rule check fails, do one of the following: 

• Select Figures Alternate Text in the Accessibility Checker panel and choose Fix from the Options  
menu. Add alternate text as prompted in the Set Alternate Text dialog box. 

• Use the Tags panel to add alternate text for images in the PDF. 

• Open the Content  panel and right-click (Windows) or Ctrl-click (Mac OS) the content that you want 
to mark as an artifact. Then, select Create Artifact from the context menu. (To display the Content 
panel, choose View > Show/Hide > Navigation Panes > Content.) 

(Screen shot coming soon) 
 

NESTED ALTERNATE TEXT 

Screen readers don't read the alternate text for nested elements. Therefore, don't apply alternate text to 
nested elements. To remove alternate text from nested elements, do the following: 

1. Choose View > Show/Hide > Navigation Panes > Tags. 

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
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2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Tags panel and choose Properties 
from the context menu. 

3. Remove both the Alternate Text and the text to which it's applied from the Object Properties dialog 
box, and then click Close. 

(Screen shot coming soon) 
 

ASSOCIATED WITH CONTENT 

Make sure that alternate text is always an alternate representation for content on the page. If an element has 
alternate text, but does not contain any page content, there is no way to determine which page it is on. If the 
Screen Reader Option in the Reading preferences is not set to read the entire document, then screen readers 
never read the alternate text. 

1. Right-click (Windows) or Ctrl-click (Mac OS) an item to check. 

2. Open it in the Tags  panel. (To display the Tags panel, choose View > Show/Hide > Navigation 
Panes > Tags.) 

3. Remove the Alternate Text from the Tags panel for any nested item that has no page content. 
(Screen shot coming soon) 
 

HIDES ANNOTATION 

Alternate text can't hide an annotation. If an annotation is nested under a parent element with alternate text, 
then screen readers don't see it.  
To remove alternate text from nested elements: 

1. Choose View > Show/Hide > Navigation Panes > Tags. 
2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Tags panel and choose Properties 

from the context menu. 
3. Remove the alternate text from the Object Properties dialog box, and then click OK. 

(Screen shot coming soon) 
 

OTHER ELEMENTS ALTERNATE TEXT 

This report checks for content, other than figures, that requires alternate text (such as multimedia, 
annotation, or 3D model). Make sure that alternate text is always an alternate representation for content on 
the page. If an element has alternate text but does not contain any page content, there is no way to 
determine which page it is on.  
If the Screen Reader Options in the Reading preferences is not set to read the entire document, then screen 
readers don't read the alternate text. 

1. Choose View > Show/Hide > Navigation Panes > Tags. 

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Tags  panel and choose 
Properties from the context menu. 

3. Remove the alternate text from the Object Properties dialog box, and then click OK. 
(Screen shot coming soon) 
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ACCESSIBILITY ISSUES IN TABLES 

Because table structure can be complex, it is best practice to check them for accessibility manually. 
 

ROWS 

This rule checks whether each TR in a table is a child of Table, THead, TBody, or TFoot. 
See Correct table tags with the Tags panel below. 
 

TH AND TD 

In a proper table structure, TH and TD are children of TR. 
See Correct table tags with the Tags panel below. 
 

HEADERS 

For accessibility, it's necessary that all tables in the PDF have a header. 
See Correct table tags with the Tags panel below. 
 

REGULARITY 

To be accessible, tables must contain the same number of columns in each row, and rows in each column. 
See Correct table tags with the Tags panel below. 
 

SUMMARY 

Table summaries are optional but can improve accessibility: 
1. Choose Tools > Accessibility > Reading Order. 

 
2. Select the table by drawing a rectangle around it.  
3. In the Reading Order dialog box, click Table. 

 
4. Right-click (Windows) or Ctrl-click (Mac OS) Table. 

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
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5. Click Edit Table Summary. 

 
6. Enter a summary and click OK. 

 
 

CORRECT TABLE TAGS WITH THE TAGS PANEL  

Use the Reading Order tool to make sure that tables are tagged correctly. If you need to structure figures and 
text within the cells of your table, you may prefer to re-create the table in the authoring application before 
you convert it to an accessible PDF. Adding tags on a cell level in Acrobat is a labor-intensive procedure. 
 
Before you make any changes to table elements, use the Reading Order tool to determine that the table is 
tagged correctly. 
 

CHECK TABLE ELEMENTS: 

1. In the Tags panel, expand the tags root to view a table tag. 
2. Select the table tag <Table> and verify that it contains one of the following elements: 

a. Table Rows, each of which contains Table Header <TH> or Table Data<TD> cells. 
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b. <THead>, <TBody>, and <TFoot> sections, each of which contains Table Rows. (The Table Rows 
contain <TH> cells, <TD> cells, or both.) 

3. Do one or more of the following: 

• If the tag for the table doesn’t contain these elements, but rows, columns, and cells appear in the 
table in the document pane, use the Reading Order tool to select and define the table or individual 
cells. 

• If the table contains rows that span two or more columns, set ColSpan and RowSpan attributes for 
these rows in the tag structure. 

• Re-create the table in the authoring application, and then convert it to a tagged PDF. 
 

SET COLSPAN AND ROWSPAN ATTRIBUTES:  

1. In the Tags panel, select a <TD> or <TH> element. 
2. Choose Properties from the options menu. 
3. In the Touch Up Properties dialog box, click the Tag panel, and then click Edit Attribute Objects. 
4. Select Attribute Objects, and then click New Item to create a new Attribute Object Dictionary. 
5. Expand the new dictionary, select the Layout attribute, and then click Change Item. 
6. Change the Layout value to Table. 
7. Select the Attribute Object Dictionary and click New Item. 
8. In the Add Key and Value dialog box, type ColSpan or RowSpan in the Key box, enter the number of 

columns or rows spanned in the Value box, choose Integer from the Value Type pop-up menu, and click 
OK. 

(Screen shot coming soon) 
 

ACCESSIBILITY ISSUES IN LISTS 

LIST ITEMS 

The check reports whether each List Item (LI) is a child of List (L). When this rule check fails, the structure of 
this list is incorrect. Lists must have the following structure: A List element must contain List Item Elements. 
And List Item Elements can only contain Label Elements and List Item Body Elements.  
 
To fix the list structure: 

1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-clicking (Mac OS) the 
failed element and choosing Show in Tags Panel. 

2. Create elements, change the types of elements, or rearrange existing elements by dragging them. 
(Screen shot coming soon) 
 

LBL AND LBODY 

Lists must have the following structure: A List element must contain List Item Elements. And List Item 
Elements can only contain Label Elements and List Item Body Elements. When this rule check fails, the 
structure of this list is incorrect.  
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To fix the list structure: 
1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-clicking (Mac OS) the 

failed element and choosing Show in Tags Panel. 
2. Create elements, change the types of elements, or rearrange existing elements by dragging them. 

(Screen shot coming soon) 
 

ACCESSIBILITY ISSUES IN HEADINGS 

• APPROPRIATE NESTING 
This rule checks nested headings. When this check fails, headings are not nested properly.  
 
To fix the list structure: 

1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-clicking (Mac OS) the 
failed element and choosing Show in Tags Panel. 

2. Create elements, change the types of elements, or rearrange existing elements by dragging them. 
(Screen shot coming soon) 
 


